CZ Firearm Forums : CZTalk banner
1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Air gun Trigger Grey Line Gun barrel

Air gun Trigger Line Gun barrel Gun accessory
Help!! I just got my gun back from a cerakote/laser engraver and I was putting my frame back with upgraded parts and I can’t figure out what I did wrong. All the parts are in, I’ll strip it again tomorrow but does anyone have any ideas what it could be? First off the hammer wouldn’t come back at all, then I fixed the hammer but the trigger wouldn’t work in DA but the SA would. Now the DA will pull the hammer back but not fire and the SA will sometimes work but it mainly acts as the decocker and puts it in quarter cock while the decocker sends it fully home. I haven’t polished or sanded anything but I did put some oil on the main parts but not the internal frame or trigger bar.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Vehicle Watercraft Automotive wheel system Auto part Boat

Hand Sleeve Finger Gesture Wood

Hand Bumper Automotive exterior Line Finger

Automotive tire Tire Gadget Wrist Engineering

Air gun Trigger Machine gun Bumper Office equipment

Automotive tire Wood Motor vehicle Vehicle Automotive lighting

Wood Automotive tire Tints and shades Engineering Bumper

Vehicle Machine Toy Engineering Auto part

Wood Camera accessory Gun accessory Carbon Auto part

Motor vehicle Office equipment Automotive wheel system Auto part Machine

i for the life of me can’t figure out what I’m doing wrong. The same problem, DA doesn't work, SA is acting like the decocker and the decocker is sending the hammer fully home.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #9 ·
did you watch the Mcarbo video? it goes through a total disassembly and reassembly of the entire hammer/decocker system. you might want to look at the YT video for changing the decocker to a safety. the only thing i see that looks a little off is the decocker spring looks offset. could it be in backwards?
Yes I did, at this point I’m able to take it apart and put it back together super easily. What I did after sending those pics is I took out all the upgraded internals and put the OEM back in and now it runs like butter. So I still don’t know what the problem is but at least it works again I guess.
And I don’t think it was on backwards? The long leg went in the hole, the short leg stuck out towards the front of the gun and I pushed it below the ledge on the decocking lever.
 
1 - 5 of 5 Posts
Top